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Asrecentlyas the early 1990, artists could only have dreamed of the im-

agesthatdigital imaging now makes possible. With the growing pop-

ularityof digital imaging, features are being improved or added every
year.Thischapterwill introduce severalenhancementsto the basic imag-
ing proced u res.

Curvescontrol tones and colors. Curves are the most powerful tool for

controllingbrightness, contrast, and color balance. Using curves, almost

anyimagecan be made perfect.

Layerscreate composite images. Adobe Photoshop allows you to cre-

ateimagesconsisting of multiple layers. Layers are separate images that
lloatabovethe background. You can- make composite pictures by bring-

ingtogetherimages from different sources.

Adjustmentlayers protect image data. A drawback to the early tools of

digitalimaging was that after many color corrections and contrast changes
wereperformed on an image, data was lost and unwanted color artifacts
wouldappear. Adjustment layers are a way to preserve all the color and
lanaiinformation in an image, no matter how much editing is done to it.

Masksare advanced tools for making selections. They make it easier to

create,edit, and reuse selections. With masks, you can create and edit

complexselections and save them for later use.

Youcan change the past. The history brush and the Fade command

makeit possible to modify editing steps that you have already taken.

Opposite) TicketholderANNA ULLRICH

:ontemporary photographers are creating composite images from the most
Inusualingredients. Photographer Anna Ullrich says about this image, "The
nolefigure is from a photograph I took of a taxidermist reaching into an em-
IOimedorca whale's mouth. The landscape and faint image of a woman's
]ce in the sky are appropriated photographs; the woman's face is incidentally
oma photograph of my grandmother. The remaining imagery (the ticket, the
Jpemeasure, the cloth) are obiects that I scanned on my flatbed scanner."

JILLGREENBERG Soles

In this advertisement for Toshiba consumer

electronics, Jill Greenberg combined five separate
images: the man, the TV and stereo speakers, the
furniture, the picture on the TV, and a miniature
model of the room.

The image was created in 1994 with an
early version of Adobe@ Photoshop@, one that did
not have the layers feature (page 66) Without

layers, each of the elements had to be positioned
exactly, with no margin for error and no possibility
of revision at a later time. Layers make creating
composite images easier and less stressful.
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Layers
THE BESTWAY TO COMBINE IMAGES

Using layers is the most reliable and quickest

way to combine images. Layers are images

within the image. They appear stacked on top
of each other, like layers in a cake or cards in
a deck. Unlike cards, images in layers don't
all have to be the same size.

The image in a layer can be moved within the

layer; you can reposition the image in each
layer vertically and horizontally. In addition,
the stacking order of layers can be changed; a
layer can be shuffled up or down.

You can apply editing commands to just one

layer. Each layer behaves like an indepen-
dent image. Color balance, hue, saturation,
levels, selections, and brush effects can be

applied to a layer without affecting the other
layers.

A layer can be made semitransparent so you

can see through it. In addition, a layer mask

(page 80) can be applied to a layer, letting
you control the transparency more precisely-
for example, a mask can make an image in a
layer transparent or semitransparent in its cen-
ter but opaque around its edges.

Adjustment layers are a different kind of layer.

They doh't contain images. Instead, they con-
tain editing commands, such as levels or color
balance, that are applied to some or all of the

image layers below them (see page 76).

Text layers are a third kind of layer. Text lay-
ers contain numbers and letters. Text layers can

be reopened and edited (for example, like
word-processing documents).
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An image composed of layers is like a stack of glass plates with a photogrq
glued to each plate. The transparent areas outside each photograph lety~
view photographs on the layers below. You can move the pictures from sider
side or change the order of 'pictures in the stock. Left, on image composed rt
layers. Right, how the layers would look if separated

Active
layer

icon ~

;.-

In Adobe Photoshop, layers are stored in the layers palette. Tose~

~

~
the Layerspalette, choose Window> Show Layers.The order of the r;

layers in the palette matches the top-to-bottom order of the layers in t~ lo

image. The eye icon is present when a layer is visible. Making layersllii

temporarily invisible is helpful in editing other layers.

I

Iii
Many types of editing can be done to only one layer at a time. YOI!-
must click to select the layer you wish to edit; the selected layer is Iii
called the active layer. When a layer is active its nome is in boidfocei

l

lii

.and its bar is highlighted. When a layer that contains on image isoel-
it will also display a paintbrush icon beside its nome bar. Adjustment! Iii
layers and type layers don't contain images.
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Layers
CREATING IMAGE LAYERS

How are image layers created? You can cre-

ate an image layer by choosing Layer> New
Layer or by choosing New Layer from the Lay-
ers palette's options menu. Photoshop also au-
tomatically creates an image layer every time
you paste one image into another. When you
use the text tool to place text in the image, each
text entry creates its own layer.

Naming layers. Whenever you create a layer
from a menu or palette, you'll be asked to name
it. However, if you paste a picture into an
image, the layer will be named automatically.
However, it's easier to keep track of layers
when they have descriptive names ("Red Toy-
ota"). You can rename a layer by clicking on
its name in the Layers palette or by clicking the
Layers palette's options button and clicking
Layer Properties. . . (Photoshop 6).

LISAJOHNSTON uluru

Semitransparent layers can create strong visual
effects. When you set the opacity of a layer
to less than 100%, it becomes semitransparent
and the layers beneath it can be seen. In Lisa
Johnston's image "uluru" (left), the image is
composed of five layers, Three of the layers are
semi-opaque, but each has a different percentage
of opacity, The topmost loyer, a barely noticeable
series of rings centered on the red mountain, is
only 10% opaque,

Image layer options. Clicking on image layer's

thumbnail image in the Layers palette (far left)
opens a dialog box (left) in which you can
specify many effects, The Blending Option
Opacity is often the most important effect; it
allows you to make the image in the layer opaque
or semitransparenL Other Blending Options, like
Blend If, permit you to make parts of the layer
transparent while leaving the rest opaque, For
example, Blend If lets you make only the lightest
pixels of the layer opaque, Wherever its pixels
are dark, they are transparent and the underlying
image shows through the top image, Blend If
also permits separate opacity effects for each
primary color.
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Layers
HARMONIZING THE ELEMENTSOF A COLLAGE

When images are pasted into other images,
they often clash with their new surroundings.
Something about them looks wrong. If realism
is your goal, an image blended into a back-
ground must match the background in several
ways.

Scale and resolution. An object's size must
harmonize with its background. Ifan object is
placed anywhere that gives clues as to its
spatial relationship with the background, it
is easy to see if it looks too large or too small.
It's also easy to see a clash between an object
and the background if they differ in sharpness
or graininess.

A conflict of perspective can occur when two

images taken by lenses of different focal length
are combined. For example, imagine two peo-
ple shown talking face to face. The result will
look peculiar if one person was photographed
with a wide-angle lens while the other was pho-
tographed with a telephoto lens.

The quality of the light on an object can make
it look like it doesn't belong with the rest of the
picture. Sunlight casts shadows and creates
sharp boundaries between the sunlit and shad-
owed parts of an object, while light from a
cloudy sky is smooth and without shadows.
The direction of light is important, too; if the
background light appears to come from the
right, it will be distracting when the light on a
foreground object comes from the left. Con-
trast often needs to be adjusted if an object is
to blend into the background; it's distracting
when several shadows don't look equally dark.
Indoor light often comes from several direc-
tions; each light source may have a different
color tint.
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STEVENBLISS

Nature Boy (State II,

Attention to technical
details can turn a
seemingly incompatibi
mix of ingredients intoi
believable image.
Creating Steven Bliss's
allegories of boyho<XI
in a "normal"America

town requires attentio~
to scale, lighting,
contrast, and color
saturation.

In addition to

placing photographs
and digital paintings,'
layers, he carefully
paints shadows on ~e

background layers 10
anchor the objects inl
the space.

Matching color bala~
and saturation are

important to making
realistic collages. AJ.
two layers clashwiln
their background.

One layer hasa
cyan-blue color cas!
which can be correct

with the Image>

Adjust> Color Bolar'
command (orwith
Levels or Curves).

The other layer'
balanced, but ithml
much color saturoliCi
The saturation com'"

in Image> Adjust>
Hue/Saturation (().

remedy this situatioo
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ENNIFERROBIN BUEll Reflections of Humility

:adedlayers. After starting a documentary photography project about a resi-
lentialneighborhood that would soon be destroyed to make way for
rommercialdevelopment, Jennifer Buell realized that the thoughts and feelings
'yoked by the hastily abandoned homes could be expressed by nonobjective
ages.In this picture, the image layer containing the face is made semi-

'ansparentwith a change of opacity (page 67) and is desaturated so that it
sno color, only tonality. The result is mysterious and haunting.

Layers
MANAGING IMAGElAYERS

Layers are very useful, but an image with many

layers can use up all your computer's RAM and

disk space. This will slow your computer

down and make it difficult to work productive-
ly. Images with fewer layers also print more
quickly; in some cases, an image with too many

layers may fail to print or cause the computer
to freeze.

Speed up your computer by reducing the num-

ber of layers. You can merge layers together.
In Photoshop, the layers menu contains the
merge commands.

Layer> Merge Down merges the active layer

into the layer shown below it in the layers
palette.

Layer> Merge Visible merges all the visible
layers (those with their Eye icons visible in
the layers palette). The active layer must be
visible or this command will not work.

Layer> Flatten Image merges all the layers into
one layer.

Layers are saved only when the file is saved in

Photoshop format. layers are not saved in
JPEG format. Save an archival copy of your
image in Photoshop format if you believe you
may work on it again in the future.

CREATINGAN EXTENDEDFAMILY

Youwill need You'llneeddigitizedversionsof severalpicturesof yourfomily

orfriends.Yourortis«cgoalis to combinepeoplefromtheseparateimagesso

theyseemto belongtogetherorelseto maketheimageobviouslyartificialbut

occeptablyplausible.Beforeyoubegin,seeMakinga CompositeImageStepby

Steponpage70.

Procedure Usingselectiontools,copyimagesof people(withorwithouttheir

surroundings)fromtwoormoresourcesandpastethemintoa thirdimage.Con-

siderif youwantrealismoranar@ciallook.Realismrequiresmuchmorework.

You'llbecombiningimagesfromseveralsources,soyou'll needto planaheadto

ensurethatthepeople'simagesaretherightsizein rela«onto eachother.

Eachimageyoupastecreatesa newlayer,soyouconapplycolorandtonal

correc«onsto it. Youconalsomovethelayer'simageun«1youhavea

satisfactorycomposmon.

Sinceyouwill havemorethanoneimageopenonthecomputer,besureyou

don't makesuchlargefilesthatyourcomputerrunsoutof memory.If youdo,use

oneoftheLoyer>Merge.. . commands.

Howdid you do? Thisisa free-formexercise,butit will helpyoudiscoverif

youknowhowto changethesizeof images,cropandtrim them,pastetheminto

an image,andadjustthetonesandcolorsof eachindividuallayer.If yourcomposi-

«onworks,youwill createanartificialbutinteres«nggroupportrait.
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Making a Composite Image Step by Step
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... I WDWidth: 158 . dllpercent ~ IJ~ ICancelI
Height: 11531 IIpiHels ' ~1 I Outo...I

Document Size:

Width: ~
Height: ~84

jl inches ili; IJ..]Iinches :~ I ~
]IpiHeis/inch , ~ IResolution: (248

~ Constrain Proportions

~Oesomple Imoge:~ubiC w
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Plan your image. Before starting, visualize your final image and deci~

which component images you will use. Don't plan an image that's tool!
for your computer or its memory. Remember that opening several ima~:
at the same time and having many layers in an image increase the~I
mands on your computer. .

1. Sketch what you visualized. Draw a picture of your backgrou~
image and place paper cutouts of each component layer over it.W
the image components work together visually? Will they create an in!
esting image? Make changes in size and placement untilyou have a goo
design. Sketching on paper is faster than using a computer to sketchail
sign. Working on paper letsyou tryout ideas more quicklyand mulfi~
your creativity. 81

2. Inspect each component. Examine the component images toge~
at the same magnification. Do the components and the background ha
compatible contrast, color balance, and saturation? Ifyou plan a real
tic image, do the components have similar lightingqualities (hard-ed~8
light or soft light) and is the direction of the light the same? If the lig~'
incompatible, you may need to choose other components.

Examine each component to see how difficult it will be to remove
from its background. If the selection process will take too much time,~
may wish to use another component image. t

e
n

3. Adjust all the components. Compare your sketch with the com!.
nents on the screen. Will you need to resample any of the compon~~I
(page 30) so that they all have the right size? Components that are11t
large can be scaled down, but components that are too small may~ a,
to be rescanned at a higher resolution.Ifyou need to make scansfor~(F.

missing components, be sure their pixel resolutions are compatible. q
When reducingthe size of the component,use the Image> Image~

command. Checkmark the Resample Image box and select Bicubic~
its pull-down menu. Bicubic resampling retains the highest image qud'6;
although it takes more time than other options. ~

Adjust the contrast, color balance, and saturation of all the comln!
nents. Youwill get a chance to fine-tune them later, so this adiustment~
be approximate. ,



4,Selecta component and copy it. The right selection process will make
'Icomponentimages blend into the background image more easily. Almost
allselectionprocedures are easier and more precise ifyou zoom the mon-
;Iorimageto 200% to 400% magnification.

I Ifthebackgroundof the final image and the componentimage are ab-
solutelyidentical, select the area you wish to copy with the lasso tool.
Featherthe selection and draw the selection away from the subject so
thatnone of it is in the feathered area.

I Ifthebackground mustbe removed around the edges of the subject,
tryselectingthe background with the magic wand or the Color Range
command.Then use the Selection> Inverse command to deselect the

backgroundand select the subject.

I Ifthebackground mustbe removed, but the edges of the subject are
outof focus or difficult to work with (such as hair), make selections
witha pen tool (page 48) because pens are precise and allow selec-
tionboundaries to be changed later if they are not perfect. Many
experienced users prefer to use layer masking (page 80), another
processfor creating editable selections.

I Dedicatedmasking software, like Extensis Mask ProTM,works in
conjunctionwith Adobe Photoshop. These auxiliary programs offer
sophisticatedtools that simplify creating selections.

I

Aftermakingthe selection, save the selection (page 83) in case you need
10redoit.

15.Copythe selection and paste it into the background image. Usethe
~ovetool (in the main toolbar) to position the new layer over the back-
I~round.Examine how well the new layer blends into the picture. If too
uchof the old background remains around its fringes, you might try
rasingtheunwanted fringe with a tiny brush. Ifthis doesn't work, you'll
!edto redo the selection process.

Evaluatethe layer's overall quality. Is the image on the new layer the
,ghtsize? If it's too large, you can scale it (Edit> Transform> Scale); if
stoosmall, you'll need a larger original. Are the contrast, color bal-
ce,and saturation correct? You can use a grouped adjustment layer
Jge76) to correct the contrast and color imperfections of anyone of your
mponentimages.
Repeatsteps 4 and 5 for each of the images you add.

Ifyouflatten the final image (Layer> Flatten Image) to make it print
requickly,keep a copy of the original with all its layers, in case you

to edit it again.

g
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Curves
THE PROFESSIONALWAY TO CONTROL TONES AND COLORS

A curve is a line on an interactive graph.

When you move the line and change its shape

(by clicking and dragging), the image's tones
change interactively.

The Curves command changes brightness,
contrast, and color balance more powerfully
than the Levels and Color Balance commands.

levels lets you adjust only three points on the
tonal scale: black, middle gray, and white;

Curves letsyou adjust as many as fourteen gray
points, which are more than most images need.
In addition to a curve for the combined colors,

there is a curve for each primary color. Thus,
curves will do what the Color Balance

command does-and do it with more power
and control.

Before editing. This image has
good white tones and black tones,
but the mid-tonesare too dark.
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output
tones-
black

(bottom)
to white

(top)

The input tones-black (left)
to white (right)

Using a curve to correct too-dark tones

255
Output
value195

127

63

Correction with curves. Correcting this
image with curves is easy. Since the
problem is that the mid-tones are too
dark, the middle of the curve is dragged
upwards (the mid-tones are in the middle).
Whenever the curve is moved upwards,
the tones become lighter.

Instant feedback. Photoshop shows you

the effects on the image as the curve is
being dragged if the Preview box is
checked.

The curve as it app€(\

before any editing.

The curve is the strai~
line from the bottom I~

corner of the graph I~

the top right corner.

Bending this line

changes the tones of!

image.

Understanding inpuIW

output is the key to

using curves. Wnej'
the curve is bent or

moved, the brightne~

of the pixels chongesj
If the curve moves

down, the image's p~
els become dorker.l~

the curve moves up,.

image becomes lign~

1
(

tI

L

c

t
c
C

E

. h
After editing. The middle tones
are now clear and visible.

c
n



IeCurvesdialog box (below). There are
'0ways to open curves. Image > Adjust>

;urvesopens the ordinary curves control.
~yer> New Adjustment Layer> Curves
penscurves in on Adjustment layer (see page
'6foradjustment layers). Both types have the
meinterface and change the image's appear-

neein the same way.

The illustration shows the appearance of the
urvesdialog box before any changes have
enmade to the curve.

~c~ -~ -~curue$i

r channel:[RGB

im:I:I:::;;

Input:

Output:

Iesteepness of the
rye controls the con-

'astof the image.
!h,a steep curve
akesan image
ntrasty.

Center, a flat curve

ivesthe image low
ntrast.Curves can be

town with many differ-
rt levels of contrast.

At right, the image
IIIOS contrasty shadows

mdhighlights, but the
idtonesare flat.

-~E!I

ill
ij OK I
I Cancel I

I load... I
I SaDe... J
I Smooth I
I Ruto I

1/1/1/1

~Prel/iew

EU]

Curves
USING CURVES

I
I

c:
'E

~
Q)

'c
c:
0

co

Getting information about the image. When you place the cursor in the
image and hold down the mouse button, information about brightness
appears in the curve dialog box.

. A circle appears on the curve; it shows the brightness of the pixel under
the cursor.

. The same information appears in numerical form below the curves graph.
Input shows the brightness value (0 to 255) of the pixel before the curve
was edited, and Output shows the pixel's brightness value after editing
(the current value).

Moving the cursor with the mouse button held down lets you sample pixels
from many places in the image. As the cursor glides around, the circle on the
graph moves and the corresponding numbers change. The information you
gain can help you decide how to place new points on the curve and which
way to drag them to change their brightness.
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I Curves
USING CURVES

or;

.. .......

~
1.,011...., ..

..

Color corrections willil
curves. The Curves

oIog box has a curve
for the combined cola;

plus individual curves,.
for each color.

Here, the green curvel
used to correct a calC!!

problem. In the
scanned image at le~1
green was overexpo~
in the bright areas a~
underexposed in the
shadows, causing mal
genta shadows and
greenish highlights.
At right, the greeneill'
is raised in the shadCII

(which adds green)iii
lowered in the highli~tl
(which subtracts grools

.. iii

USING CURVES

TheCurvescommandis thesinglemostpowerfulcorrectiontool

availableto digitalimagemakers.Thisprojectwill helpyou

learnhowcurvescanaffecteveryaspectof animage.

Youwill need Adigitlzedcolorimagewitha full rangeof

tonesandcolors.It shouldnotbebiggerthanyourscreenat

100%magnification.Youwill bemakingmanychangestosee

howthecurvesaffectthe image,sosavea copyof theimage

in caseyouaccidentallychangetheoriginalpermanently.

Procedure UseanAdjustmentlayerto makeyourchanges.

SelectLayer>NewAdjustmentLayer>Curves.

Besurethe Previewboxison (placeanx in thebox)sothat

the imagewill changeasyoueditthecurves.Beforeyoubegin,

clickondifferenttonesof the image.Thismakesa markerap-

pearonthecurvecorrespondingto thebrightnessof thepixel

youclicked.Usethismarkerto learnabouttherelationshipof

thecurveto the image.
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Clickonthecurveto createpointsanddragthemuntilyou

have createdcurvesshapedlike those picturedhere.Try011

these curveshapesplus as many othersas you canimagine.

Are placesin the image where the contrastappearsflatossOO!

atedwith steeporflat partsof thecurve?Noticehow~e(Ii!

trast and color saturationof the image changeswith ea(~1
of curve. Noticehow small changesin the curveshapeaffect,

theimage. I
Next,experimentwith changingthecurveof onecolor,leol

theothersunchanged.Thentry givingeachcoloradifferent

curve.Seehowmanycoloreffectsyoucancreate.

Howdid you do? Inthisfree-formproject,youshoulo

seenmanyradicallydifferentversionsof the image.W~enI

curveissteep,the imageshouldhavehighcontrast.W~en

thecurveisflat, theimageshouldhavelowcontrast.W~eII

curvezigzagsupanddown,theimageshouldshowpostern

tion,a specialeffectinwhichthetonesof theimageseem

unpredictablyjumbled.



Usingcurvesto enhance the dark areas of the scene. At sunset,the bright sky silhouettesbuildings on
Inehorizon,and the rooms lit by fluorescentlights are barely visible, as seen at left. Using the curve
,nownat right, the dark areas of the scene are made lighter and given more contrast, below.

Amaskedadjustment layer. (page 81) could create the same appearance. The sky would be masked
50Ihatthebrighteningeffect would be limited to the dark parts of the image.
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Adjustment Layers
PREVENTINGCOLOR BANDING AND DATALOSS

Normally, as you edit an image, its data is

altered forever. For example, if you change
gray pixels into white ones, the changed pixels
are given new values of red 255, green 255,
and blue 255. After you finish work and turn off
Photoshop, all records of the original values are
lost forever. Often, after a series of edits, the

original data can be so altered that only a small
fraction of the original 16 million colors remain.

The result can be that that banding becomes
visible (see left).

Adjustment layers are permanently undoable

and perpetually redoable. Adjustment layers
(layer> New Adjustment layer) allow you to edit
many aspects of the image without ever chang-
ing the original pixels. An adjustment layer con-
tains no image, just commands that alter tones
and colors in the layer(s)beneath it. It is important
to grasp the idea that the adiustments never alter
the original pixels-the original data from the
scan or camera is preserved. As a result, an ad-

justment layer's effects are permanently "un-
doable," even if you reopen the image years later.
Note: the History palette letsyou undo an almosl

unlimited number of changes, but the history is
erased when you close the image. You cannot
undo anything when you reopen the image.

Professionals who edit digital images use adjustment

layers as often as possible. Although adjustment
layers greatly increase the size of an image's file, their
Rexibility makes them essential. For example, despite ad-
vances in color management technology (seepage 98)

an image will often appear different when printed on
different models of inkjet printers. When printed on film
(see page 107) or by offset printing press, the image's
appearance will vary widely. So, for each situation, a
professional must prepare an alternative version of the
image-a considerable amount of work. It's easier if

the image can simply be reopened and the necessary
changes made to the settings of the adjustment layers.
Best of all, the settings of the adjustment layer can be
saved as files and thus old versions of the images can
be recovered if needed again.
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Without adjustment layers, colors can show bands. Left, an image and i~t:
togram. This image was previously edited with Curves, Color Balance, Hue,ll
Saturation commands. Banding is visible; the tonal gradation has an abruptstr
case appearance instead of a smooth, normal transition. A histogram can beBi
used to diagnose banding. Thisone has gaps. It looks like the teethof a conqn

These gaps represent brightness levels where data was discarded during edh

At right is the Levels histogram for an image layer that has had the sam~!
editing done with adjustment layers. The image has smooth gradations, andll
its original tones are present in the histogram. I

This icon identifies it as a Hue/Saturation
adjustment layer. The icon varies with
each kind of adjustment. This icon indicates

that is a layer
containing a mask.

c.h!!l!I.ili..~f.~JbL~

a.city:~

Fill:It 00% II

The eye icon is present in every kind of layer,
so the effects of an adjustment layer can be
clicked on or off.

h

Adjustment I~
appear in the!
Layers palelfe,\
Instead of

displaying a
paintbrush icct
the left of its

name, an

adjustment la~
displays an i~
that indicates!

"mask" (see

masks, page4n

The layer's ti~~:.
bar shows a~')
icon that idenl

what kind oI~

j

'

adjustment itfr
such as Cu~r
Hue/Saturati~
Levels, etc. ff



ad[ustmentlayer normally affects all the
~rsbeneath it. However, if you want to limit
effects,you can group it with the layer immedi-
;~below it in the Layerspalette. First,select the
iustmentlayer; then use the command Layer>
Jpwith Previous (Photoshop 7 and earlier) or
iteclipping mask [Photoshop CS). Layers
leaththe grouped (clipped) layers are not
;tedby the adjustment layer.

l!lendingOptions offer
Imnmorecontrol over

heimage. Like image
'eyers,thetransparency
'on adjustment layer is

:ootrolledby setti ng the

Jpacifywith the com-

1and layer> Layer

Is \;~e> Blending Op-
,Ions.. . . In this dlustra-

~on,a curves layer is

1ppliedto an image
,~ditseffects are

ded back with a

decrease in opacity.

:enter, the image

'leloreadjustments are

~ade. Bottom, the

'~ageadjusted with a
'lVesadjustment layer.

'\e amount of adiust-
lenl was excessive.

~nom right, the adjust-

~nt layer is set to 65%

:p:Jcify.While decreas-

19opacity reduces

IJevisibility of an

'~age layer, in on ad-

,uslmentlayer, it de-
creasesthe power of

~eadjustment.

I
I
I

~ " ,~~~ ~~'~

""".",i '

",

"

i'fJ}l
," 8.:.:--- ~

,

'

"
,,

",
,

" "<

,

.

,

:\'
,

"~ 'r ---, -~

ITr ~I

-i

--

Indented thumbnail with
downward arrow indicates

that this layer is grouped
with the one below it.

Underlined layer
name indicates that this

layer is grouped with the
one above it.

Adjustment Layers
USING ADJUSTMENTS

Adjustment layers affect all the image layers
below them in the Layers palette. However,

you can clip (group) an adjustment layer with
one designated image layer so that it affects
only that one layer. The grouped layer must be
the one below the adjustment layer. A grouped
set of layers takes a distinctive appearance in

the layers Palette.

Use adjustment layers with special effects.
Many of the special effects that can be applied
to image layers can also be applied to adjust-

ment layers. For example, the opacity settings
embedded in the layer can be set from 0% to
100%. If an adjustment layer is set to 50%
opacity, the power of the adjustment will be
reduced by 50% (see illustration).

There are limits. Not all image-editing oper-
ations can be done in adjustment layers, but
many important ones can: levels, Curves, Color
Balance, and Hue/Saturation. Certain special
effects, like drop shadows and text effects, can

also be applied in adjustment layers. Unfortu-
nately, at this time, adjustment layers cannot
be used to change image resolution or to apply

filters like Unsharp Mask.
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Using Masks to Create Selections

Masks are the most professional way to cre-
ate selections. Thinkof a mask as a sheet of

plastic that lies on top of an image. Wherever
you cut holes in the plastic you can edit the col-
ors and tones of the image beneath; but wher-

ever the plastic is solid nothing can change the
image-the image is masked.

One advantage of masks is variable density.

While ordinary selections have feathered or

anti-aliased edges, a mask lets you make any
part of a selection opaque, transparent, or in
between. Wherever a ma~k is transparent, you
can edit the image normally. Wherever a mask

has partial density, the editing effects are par-
tial. For example, if you increase contrast, the
image under the transparent areas of the mask
shows high contrast but the image under the
semitransparent areas of the mask shows only
a smaller increase in contrast.

Masks are not selections; additional commands
are used to create selections from masks.

For example, in the Channels palette, clicking
the "Load channel as selection" icon turns the

currently highlighted channel into a selection.

fA channel is the place where a mask is per-

manently stored. See page 83.)

Seeing through a mask. A mask can be eas-

ier to use than an ordinary selection because

of its visibility. Ordinary selections are visible

because their edges are mark~y a moving
marquee (the marching ants). But if it's a feath-
ered selection, the marquee doesn't show ex-

actly where its edges are. A mask is better; you
can see all of it. A mask appears on the mon-
itor as a blanket of color over the image.
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Problem: to remove the figure and paste it into another image. TopleH),6.
figure with a selection drawn around it. The hair is a problem, however,~Ia'y
only roughly selected. More work mustbe done on the hair. Top right,the~Th~
lection is turned into a mask with the command Select> Save Selection,se/:

The mask is shown as a light red where is it opaque and is transparentov~imd
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Below right, after painting on the mask, the mask was turned into a seledi
with the command Select> Load Selection. . . . The selected area was' re
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~singa mask created

10man imag~ to cre-

,alespecial effects in

,anotherimage.

Iiond2. A landscape
"nda grayscale image
Idadancer.The
'dancer'simage will be
,!ledtocreate a ghostly
magein the landscape.

], Achannel(see

~ge83) is created in
Ielandscape.It is
lamed"ghost image."

Thedancer'simage is
~Iecledby outlining,
nencopiedand posted
110thelandscape's
~wchannel.(4) This
creolesa mask contain-

~gan imageof the
xmcer.

I

I The"ghost image"
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'i~eyaffectonly the
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Name:19host imag~

Color Indicates: . "

.. Masked Rreas
<IISelected Rreas

Opacity: EI %

The colored blanket is most thick where the mask

is fully opaque and is transparent where the
mask is transparent. You choose both the color
of the mask and how opaque you want it to ap-
pear on the monitor. (Usually you don't want a

mask to be so opaque that you can't see the
image beneath it.) You can also temporarily
make the mask invisible if it gets in the way of
seeing what you're doing.
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Adobe Photoshop treats masks as grayscale

(a-bit) images. This has significant conse-

quences. Because the software treats masks like
images, you can edit them like images. This
means you can use a brush to paint on a mask,
making the mask either more opaque (blacker)
or more transparent (whiter).

Because masks are treated as images, you

can also paste shapes and other images into
masks. For example, you can put text into a

mask; the shapes of the letters can then be
transformed into colors or effects. You can paste

images into masks (but only 8-bit grayscale im-

ages, see left). In fact, because a mask is a
grayscale image, you can apply any of the
non-color editing techniques discussed in Chap-
ters 3 and 4.

Selections can also be turned into masks.

Clicking the "Save selection as channel" icon
in the Channels palette turns the selection into
a mask. Why should you do this? Most com-
plex selections'start with a simple selection, the
kind you might make with the lasso tool or the

magic wand; by turning them into masks, they
can be edited more precisely. Then, they are
turned back into selections. This may sound un-

necessarily complex, but it is a powerful tech-
nique. It is helpful for making extremely
complex selections, such as outlining the hair
on someone's head.
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Layer Masks
ATTACHING A MASK TO A LAYER

A layer mask is a mask attached to a layer.

They are useful because the mask only affects

the layer; the rest of the layers are untouched.
Three types of layer masks are useful to pho-
tographers.

Image layer masks. A layer mask can make
part of an image on its layer invisible: wher-
ever the layer mask has full density (blackL the
image is hidden; wherever the layer mask is
transparent, the image is visible. A partially
erased mask makes the layer's image partially
visible. -

Outlining an object is a common use for
an image layer mask. By painting the mask
black around the object, you'll make the layer
around the object disappear. First, create a

mask by choosing Layer> Add Layer Mask>
Reveal All. As a result of choosing Reveal All,
a transparent mask is created. When you paint
black onto the mask, that part of the image be-

comes invisible. This is a forgiving procedure;
if you make an error while painting, you can
erase and repaint.

Text layer masks. Layer masks can be used

to make parts of a text layer transparent or semi
transparent. This extends the range of special

effects that can be applied to text in images.
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Layer Masks
ADJUSTMENTLAYERMASKS: PROFESSIONAL-lEVELPHOTOSHOP

Maskingan adjustment layer. A m_askattached to an adjustmentlayer con-
lolstheintensityof the layer's effects. At left is an image in which an adjust-
mentlayerwas used to decrease contrast until the image was a featureless
gray.However,the mask, right, protected the central area of the image and
preservedits normal contrast.

Agraduatedmask on an adjustment layer. Left,the aerial photograph has a
lcorrectableproblem: atmospheric haze becomes thick and blue as the distance
I,ncreases.The distant areas need more contrast and less blue. A curves adiust-
Ilentlayerthatdoes thissatisfactorilyfor the distantareas was created, but it
lipoilsthenearby areas. The solution is to gradually mask the adjustment layer
,~Ihatitis transparent in the distance and opaque in the foreground.

~

Adjustment layer masks. A mask attached to
an adjustment layer can reduce the intensity of
the adjustment layer's effects. On the previous
page, you read that a black mask on an image
layer makes the image invisible. Byanalogy, a
black mask on an adjustment layer makes the
adjustment invisible. For example, you already
know that if you place a Hue/Saturation ad-
justment layer over an image layer, you can in-
crease the color saturation of the image. Butif
you paint black on the mask, those parts of the
image beneath the black mask will show no in-
crease in saturation-they are masked from the
effects of the adjustment.

The power of Photoshop is enormously en-
hanced by masked layers. When you master
the use of masked layers, you move into the
higher realms of digital editing. Masking an
adjustment layer lets you" dodge and burn"
tones and colors, changes you can easily mod-
ify or reverse at any time. Masking also lets
you work quickly and experiment with ideas in
rough draft form. Imagine having to tryout sev-
eral versions of an image. Youcan make drafts
by using adjustment layer masks to control col-
ors and tones. Youdon't have to spend a lot of
time getting the edges of the masked areas to
be perfect-you can do that later, after you
have chosen the best image.

Storing layer masks. Creating an adjustment

layer automatically creates a transparent mask
in the Channels palette (see page 83 for how
masks are stored). Whenever the adjustment
layer is active in the Layers palette, its mask
becomes visible in the Channels palette. Masks
for image and text layers are not created au-
tomatically. You must use the command Layer>
New layer mask to create a mask.
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Threetypes of channels

1-4.Color channels. The Red, Green, and Blue channels and the RGB

,[composite)channel are part of every RGB image (see page 84).

5.Adjustment layer masks (page 81) appear when its corresponding
adjustmentlayer is selected in the Layers palette. Only one adiustment layer
maskisdisplayedat any time, no matter how many adjustmentlayersthe
imagecontains.

16.Alpha channels. The channel "Alpha 1-clouds" (named by the photog-
rapher)is a mask that was created to lighten the dark tones in the clouds.

7.Quick Mask. There is a second type of alpha channel on this palette, a
QuickMask. Quick Masks are convenient but temporary alpha channels in

IAdobePhotoshop. They are created by clicking the Quick Mask Mode icon on
I~etoolbar (not shown). You can convert a Quick Mask into an alpha channel

'DYloading it and saving it, but you can have only one Quick Mask at a time.

i. TheQuick Mask is the red-tinted area covering the image. It is visible in

lineimage window because its eye icon is switched on. Note that the eye
Iconsof the adjustment layer mask and the alpha channel are switched off.
Maskswhose eye icons are not visible cannot be seen in the image window.

Alpha Channels
WHERE MASKS ARESTORED

Masksare stored in the Channels palette

where they are called alpha channels. Because
color channels are also found in the Channels

palette, it is important to know that the two have
little in common. Color channels contain the

color information about an image (see page

84). The information in color channels is part
of the image; they are visible in the image.
However, masks stored in alpha channels are

not part of the image; they are never seen in the
image. Alpha channels are merely storage
areas for masks-nothing more-and masks

are just editing tools that help create selections.
You never see the mask itself in the image.

Alpha channels are a part of the image's file;

they may remain when the image is saved.
Their disadvantage is that they increase file

size. For example, an RGB image file that is
three megabytes can expand to four megabytes
with one alpha channel.

When your image editing is complete, you

may have no reason to keep them, so you can
drag the alpha channels to the trash can in the
Channels palette. Don't discard them if you ex-
pect to rework the image later. If you want to
keep them, save your files in Adobe Photoshop
format. Some formats, like JPEG, can't save

alpha channels.
Note: while discarding alpha channels, be

careful not to unintentionally discard masks

attached to layers. Masks, whose names ap-

pear in italicsin the Channels palette, are not
alpha channels. It is also possible to discard
the color channels. Normally, this will ruin the
color balance.
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Color Channels
WHERE COLOR INFORMATION IS STORED

Color channels store information about colors.

An RGB image has three color channels: red,

green, and blue. A CMYK image has four color
channels. Each color channel is a grayscale

image with 256 brightness levels. Each is an in-
dividual image, just as the three layers in color
film are individual images. Like the three layers

in film, color channels appear blended togeth-
er when the image is viewed normally. How-

ever, editing software can also display each
channel separately or in combination with one
or more of the other channels.

What's the difference between a layer and a
color channel? Because color channels add

to the complexity of the software, it's important
to know the difference between a layer and a
color channel.

. A layer is an individual, full-color image.
Layers can be stacked to create a compos-
ite image.

. Color channels are the color components

of a layer. Each RGB layer has three color
channels.

. When you edit color channels, you edit the
color channels of one layer at a time. The

active layer (the one selected in the Layers
palette) is the only layer where the color
channel editing is happening.

Sometimes it helps to edit only one color
channel. On occasion, one channel is less

sharp than the others, or it may appear too

grainy. To fix this, you might remove grain in
one color channel by blurring it with a filter,

while you sharpen another color channel with
a different filter (see Filters, page 89).
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An RGB image has three color channels. Individual color channels ore
displayed as thumbnail images in the Channels palette, above. The composl'U
of all channels is labeled RGB. When the eye icon is present beside theRGmto
channel's thumbnail, the image is displayed in full color in the main image tu
window. It's best to view the individual color channel's thumbnail images in se
block-and-white (instead of color) because they ore easier to compare with ec
each other. so

me

Color channels can be viewed individuallyin the main image windowby SUI

making the other channels invisible. Channels ore turned on or off by clicki~an
their eye icons. Below, only the blue channel is visible (as a black-and-whileled
image) in the main image window. The composite channel and thegreen01 ve
red channels have been turned off (their eye icons ore not visible).
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Color Channels
EDITINGCOLOR CHANNELS

~-

Specialeffects with color channels. To create a
halo effect, a very strong Glow filter (Filter> Dis-
tort> Diffuse Glow) was applied to the red chan-
nel. Then, on Unsharp Mask (Filter> Sharpen>
Unsharp Mask) was applied to the green channel
(see Filters, page 89).

In order to edit only one channel, you must select
it in the channel palette. Note that the Green
channel's nome is highlighted; highlighting indi-
cates that the channel is active. Since it's normal

for all color channels to be active at once, you
must individually deselect the others.
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Modifying the Past
THE FADECOMMAND AND THE HISTORYBRUSH

The command Edit> Fade lets you modify the last editing

command you completed. It allows you to partially undo
a percentage of the command. For example, if you paint
something orange, you could then fade the orange to 65%

of its full opacity (in other words, the old color will show
through the orange). Or, if you used a blurring filter to soft-
en the image, the Fade command lets you restore some or
all of the sharpness. You can preview the effects, so you can
use Fade precisely. The Fade command is not available for
all commands.

radii;;!!

Opocity' FV>""1
. ~11.. IfIiKI

Made:INormol .~I ~
6i!I Preuiew

The History brush (in the main toolbar) is like a time ma

It allows you to restore part of an image to the way it 100
earlier in your work session. Wherever you drag theHi
ry brush, the image reverts to the way it looked earlier.,1

example, if you use a sharpening filter to sharpen details/j
can reverse the sharpening effect by brushing thoses~
you want to unsharpen. You might also use the brushto
portions of a change in color balance.

The Fade command can be used

to partially undo your previous
command. Left, an image in
which the Curves command in-

creased contrast excessively.
Above, the Fade dialog box,
which appears after you choose
Edit> Fade. . . . A fade of 0%

will entirely undo the Curves
command, and a fade of 100% will leave the image with no fade. Youcan preview the effectsas you drag the slider between
100. Right, the image with the Curves command 50% faded.

The Fade command must be done immediately after the action.

I"""", 'ifflldB!! """""

If you take another action, fade becomes unavailable.
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Blending mode menu in the Fade
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'i.Ome CJSIJectsof a command. For
example, after a large contrast in-
crease to this satellite photo (left),
the color saturation mode of Fade is

selected (above). Right, the contrast is reduced to its original level (0%),but the color saturation effect that accompanied theI
in contrast remains in the faded image.



Historybrush icon

~
Current state in

History palette

istoryismadeconstantlyas you edit an image, and it is recorded step-by-
,pas"states"in the History palette. By clicking in the box beside one of the
Jles,you designate that particular state to be the source for the History brush.

,Historybrush icon appears in the box beside that state's title. Now, you are
Jdyto point with the History brush.

carefulnot to click the title of a History stateaccidentally. Clicking results
!heentireimage reverting back in time to the way it was when you created

Iestate.Thisis a very good way to undo an error you made earlier, but it
)uldalsocause you to unintentionally lose a lot of work. If you do this by mis-
Ke,youcan recover from it by clicking the title of the very last (bottom) state
Ihehistorypalette. This returns you to the present.

~

tt~

Iharpening with a filter improved this portrait, but areas of smooth skin
becamerough. The History brushcan repair the skin by returningit to the
appearanceit had before sharpening.

!hesetup is done by
Idicking the box beside
lie state that took place
justbefore the editing
roo want to modify.
',e brushicon appears
'Ihe box. Note that

'e sharpened state is

selected. Now you

'reready to use the His'
;ybrush.

Paintbrush

Paintbrush

Paintbrush

I!:

The History brush sometimes requires you to

plan ahead. In order to work, the brush must

paint from a saved copy of an earlier version
(state) of the image. These earlier versions are

called states (in the History palette) or snap-
shots, which are also stored in the History

palette (see opposite). When you select one of
these for the History brush, the brush will copy
from it as it paints over the image. For an in-

genious way to use the History brush with snap-
shots (one in which you go forward and
backward in time to complete a task), see Re-

moving Spots and Scratches on page 89.

- 1

I--.

The brush paints the sharpened image with
a copy of the image as it existed before
sharpening. Likeall brushes, it can be set
to be partially opaque; this lets you build up
the changes gradually.
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Troubleshooting
KEEPINGTRACKOF LAYERS,CHANNELS,AND MASKS

Power creates complexity. Selections, layers,
channels, and masks make imaging software
the tool of choice for thousands of artists. But

such power comes with complexity and the po-
tential for confusion. Youcan be stumped when
the software does not do what you expect it to
do. At right is a very basic list of steps to take
when things go wrong. As your experience in
digital imaging grows, develop a personal trou-
bleshooting checklist by adding to this one.

Can you solve this puzzle?

If you try to edit Layer-3, the active loyer, why will
nothing appear to happen?

Lock: D ~ D # D + D ii

l§fr- @] @ Iii Sky

~~I.G ~ I ~ I@D_~IS-

Pr-II7

l~~r:!~I.~Iii ~. I L:.W-

~ Ir- .1@ D~ay.er~2

r~~fl ~J@ 0 Curve~

~IE-. Laye~ 1
....

.....

Answer: Loyer 3 is invisible; its eye icon is
switched off. Your edits are occurring, but you iust
can't see them!

When something goes wrong, stop and think.
Make sure that you are editing where you think
you are editing-in the correct image, in the cor-
rect (and visible) loyer, and in the correct (and visi-
ble) channel.
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1. The editingsoftwarestopsworking.
Tryclosinga paletteto seeif thewholecom-

puteris frozen.. Ifapalettewon'tclose,tryswitching
fromtheimagingsoftwareto Microsoft

Windowsor theMacintoshFinder.If you

candothis,thecomputerisOKandyour

problemiswiththe imagingsoftware.

. Is your image so large that the computer

isstillworkingonyourlostcommand?

If not,youmayneedto exitandrestart

the imagingsoftware.

. If theentirecomputerisfrozen,restart
thecomputerorgethelpfromalob
technician.

2. If your lost commanddid not work like

you think it shouldhave,stopand think.

Donot issuenewcommands,asyoucouldac-

cidentallyedittheimage.Asa precaution,use

thesoftware'sUndocommondto undoyour
lostknownsuccessfulcommand.DoesUndo

workthewayyouexpect?If it does,cancel
the Undocommand.. If Undodoesnotwork,thensomething

unexpectedhappenedafteryourlost
successfulcommand.Don'tcancelthe

Undocommand,asit mighthaveundone

somethingyoudon'twont.Eitherway,

gotostep3.

3. If youstillaren'tgettingtheresults

youexpect,considersomecommonreasons
thatthiscanhappen.. Areyouaretryingtoeditoutsidethe

selection?Seethediscussionon

page 44. Also, if morethanonei

isopen,areyouconfusedabout\

imageisactive?. Areyoutryingtoeditthewro
layer? Onlytheactivelayerco

edited,butit is possibleforthe0<

layerto beinvisible;soyouredits

peningbutyoucan'tseethemha

ing! Besurethatyouhavethede

layeractiveandthatit isvisible.. Areyoutryingtoeditachann
mask that isn't visible or isn't I

It ispossiblefor theactivechanne

invisible,soyoureditsarehappen

youcan'tseethemhappening.Be

that thechannelyouwontto edit

andvisible.Also,youmayhaveth

channel,butyoumaybeworking

wronglayer.

Sometimesa commandyou wontte

is grayed out or is missingfrom the
menu. Somecommandsarenotavoi

at certaintimes.Forexample,whenon

adiustmentlayerisactive,manymenuI

aregroyedout.Theybecomeavailable(

whenon imagelayerisactive.Problems

thisarebestsolvedby readingthesof\w
manual.

Are you trying to savea file but it~
save? Youmaybetryingto savethe

a formatthatwon't acceptthefeatures

image.Forexample,youcan'tsaveaI

imageinJPEGformat.Youmaybetryin

savethefile to a diskthatcan'taccept

files,suchasa lockeddiskora CD-ROM



Digital Filters for Special Effects

~urringtheimage around the subject. The subject is outlined with a feath-
eredselectiontool. Then Select> Inverse selects the area around the subject.
!hefilterMotion Blur (Filter> Blur> Motion Blur) blurs the selection horizontally,

creatingan illusionof motion. The direction of the blur is chosen by the photog-
IJpher,andtheamount of blurring is set by numerical input.

--I

Removing dust spots and scratches

Step 1. Apply the Dust and Scratches filter to the
entire image with the command Filter> Noise>
Dust and Scratches.

Step 2. (Top left) Take a "snapshot" of the dust-
free image. A snapshot is a copy of the
image. Snapshots are stored in the History
palette. Open the History palette with the com-
mand Window> Show History. From the History
palette's pop-up menu, select the command New
Snapshot. Name the snapshot (for example,
"Dust-free version").

Step 3. (Second from top) In the History palette,
make the original (dusty) image active. You will
see two snapshots in the History palette. Click
the original, dusty image to make it active. Ac-
tive means that it is the version that is being edit-
ed. The image reverts to the way it was before
you applied the dust and scratches filter.

Step 4. (Third from top) In the History palette,
click to the left of the dust-free version of the

image to make its brush icon visible The brush
icon means that when you point on the image
with the History brush (see below), the dust-free
version will be copied by the brush, as though
the brush was the rubber stomp tool.

Step 5. Select the History brush tool from the
main toolbar palette. The History brush is a spe-
cial brush that points from one version of on image
(the source version) to another (the active version).
It's like cloning from one image to another.

Step 6. (Bottom) Use the History brush to paint
over dust spots in the original (dusty) version of
the image. This will point in the dust-free version.

Software filters are like camera filters-they

create special effects. Hundreds of digital

filters compatible with Adobe Photoshop are
available from software companies. It is even

possible for people with a limited knowledge of

.~ software programming to create their own
';; filters.'"
t::
0

ex:>

Software filters, like camera filters, can be

gimmicks that distract you from creative

thinking. Most filters are useful primarily if you
want to transform photographs into photo-
illustrations.

A few filters are useful if you want the image to

look purely photographic. Unsharp Mask

(page 102) makes focus look sharper. Blur fil-
ters (Filter> Blur) reduce focus sharpness. Noise
filters (Filter> Noise) increase or decrease the

appearance of graininess in images. Digital
graininess is the result of film grain or electronic
noise in the scanner. Some filters and tools

(such as blur filters or the smudge tool) eliminate

the graininess, with the undesirable side effect
that the blurred areas appear artificially smooth

compared to the rest of the image. A noise fil-
ter corrects this by restoring a grainy appear-
ance to the blurred areas. Select the blurred

areas before filtering.

The Dust and Scratches filter will remove de-

fects from an image, but it has the unwanted

side effect of blurring the image. However,

there is a way to apply it only to the scratched
and dusty parts without blurring the image. See
the illustration on the left for the details of this

important technique.
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